湖南快乐十分

免费注册 登录 广告服务 | 客服中心
您现在所在的是:

三菱Mitsubishi

抖音 西门子减速电机 德嘉 台达 英威腾 泓格论坛 西门子 我和LOGO!有个约会 FLIR红外热像论坛 【有奖活动】英威腾 “Ni美国国家仪器 “PLC发展趋势大讨论”活动圆满结束 cc-link图文征集活动 西门子SMART LINE V3
工控论坛湖南快乐十分 三菱Mitsubishi → 浏览主题: 关于Z相脉冲
发表新帖 回复该主题
回帖:17个,阅读:371 [上一页] [1] [2] [下一页]
* 帖子主题:

关于Z相脉冲

[已结贴]
分享到
156
幸福的熊
文章数:16
年度积分:103
历史总积分:156
注册时间:2018/11/17
发站内信
发表于:2020/6/24 12:57:33
#0楼
伺服编码器的Z相脉冲接plc,电机不动作的情况下plc的输入端常亮?
plc是npn型的,OZ接到X1(高速),GND接到24V-。怎么解决输入点常亮的问题
156
幸福的熊
文章数:16
年度积分:103
历史总积分:156
注册时间:2018/11/17
发站内信
发表于:2020/6/24 12:58:35
#1楼

27657
YXBK 版主
文章数:13190
年度积分:2200
历史总积分:27657
注册时间:2007/4/14
发站内信
2015论坛优秀版主
2015春节活动
2013论坛优秀版主
2012论坛优秀版主
发表于:2020/6/24 16:17:49
#2楼
线有没有接错,转起来是不是就不亮了,正常电机应该只在Z位时才亮的
大家一起学习
6324
jiouai84
文章数:597
年度积分:615
历史总积分:6324
注册时间:2013/1/7
发站内信
发表于:2020/6/24 17:27:05
#3楼
从你的图来看的话,OZ端应该是要电流流入的,所以,如果你的PLC是NPN的,X端子是电流流出的,所以,是不是应该是把GND和伺服的GND连在一起就行了
446
18041568892
文章数:66
年度积分:446
历史总积分:446
注册时间:2019/2/12
发站内信
发表于:2020/6/27 8:12:03
#4楼
编码器分为4中输出类型。 1.集电极输出型 2.线性输出型(差分型)3.电压输出型 4.互补输出型 每种编码器与plc接线有区别需要注意。
plc与驱动器通信一定要共0,否者会引起莫名其妙的故障。
不知道你的plc具体什么型号,建议你好好确认下plc是否支持差分编码器信号
156
幸福的熊
文章数:16
年度积分:103
历史总积分:156
注册时间:2018/11/17
发站内信
发表于:2020/6/27 8:53:24
#5楼
回复 #2楼 YXBK
静止或者运动都是常亮的,plc检测不到脉冲
156
幸福的熊
文章数:16
年度积分:103
历史总积分:156
注册时间:2018/11/17
发站内信
发表于:2020/6/27 8:55:20
#6楼
以下是引用180415688922020/6/27 8:12:03的发言:
编码器分为4中输出类型。 1.集电极输出型 2.线性输出型(差分型)3.电压输出型 4.互补输出型 每种编码器与plc接线有区别需要注意。
plc与驱动器通信一定要共0,否者会引起莫名其妙的故障。
不知道你的plc具体什么型号,建议你好好确认下plc是否支持差分编码器信号
用的是集电极输出的,驱动器是支持集电极输出的,而且确定plc与驱动通讯共0.
[此贴子已经被作者于2020/6/27 10:00:11编辑过]
156
幸福的熊
文章数:16
年度积分:103
历史总积分:156
注册时间:2018/11/17
发站内信
发表于:2020/6/27 9:03:37
#7楼
以下是引用jiouai842020/6/24 17:27:05的发言:
从你的图来看的话,OZ端应该是要电流流入的,所以,如果你的PLC是NPN的,X端子是电流流出的,所以,是不是应该是把GND和伺服的GND连在一起就行了
是共用信号地的。
27657
YXBK 版主
文章数:13190
年度积分:2200
历史总积分:27657
注册时间:2007/4/14
发站内信
2015论坛优秀版主
2015春节活动
2013论坛优秀版主
2012论坛优秀版主
发表于:2020/6/27 17:24:48
#8楼
以下是引用幸福的熊2020/6/27 8:53:24的发言:
静止或者运动都是常亮的,plc检测不到脉冲
你最好画个实际的接线图上来,就算没有信号输出也不应该常亮,应该是不亮才对的
此帖发自手机工控论坛
大家一起学习
446
18041568892
文章数:66
年度积分:446
历史总积分:446
注册时间:2019/2/12
发站内信
发表于:2020/6/28 10:19:31
#9楼
回复 #6楼 幸福的熊
1.驱动器是什么型号?驱动器参数里确认了吗?像这种差分输出、集电极开路输出驱动器可能会有参数no nc之类的设定,确认下。
2.可尝试不用z集电极输出,用z脉冲输出到plc观察一下现象是否一样.
3.我推测驱动器参数设定不良可能性比较大
[此贴子已经被作者于2020/6/28 10:36:16编辑过]
工控学堂推荐视频:

关于我们 | 联系我们 | 广告服务 | 本站动态 | 友情链接 | 法律声明 | 非法和不良信息举报

工控网客服热线:0755-86369299
版权所有 中华工控网 Copyright©2020 gzyingpai.com, All Rights Reserved

93.6